• Internet To use BIMIXS, you just need internet access and a web browser. • Browser Requirements The following browsers are supported: » Internet Explorer 7 or later » Firefox 11 or later » Safari 5 or later » Chrome 17 or later » Opera 11 or later Earlier versions and other browsers may be running, but are not supported officially.